はじめてのRuby on Rails、トラブル記録
<< Windowsでruby gemsをインストールする | TOP | named_scopeで検索結果が1件の場合 >>
スポンサーサイト

一定期間更新がないため広告を表示しています

posted by スポンサードリンク | | - | - | - |はてなブックマーク - スポンサーサイト
Windowsでrailsをインストールする
rubyがインストールされていなければ、rubyをインストール
関連エントリ:Windowsでのrubyのインストール・セットアップ方法

ruby gemsがインストールされていなければインストール
コマンドプロンプトでgem -vといれてgemのバージョンが出ればインストールされています。
出なければインストール。
関連エントリ:Windowsでruby gemsをインストールする

ruby gemsを動かすのに必要なライブラリをruby¥binフォルダに入れる
gemでrailsをインストールしようとすると、「zlib.dllがありません」「SSLEAY32.dllがありません」というエラーメッセージが出ます。
zlibとopensslのライブラリをrubyフォルダ内のbinの中に入れると、このエラーは出なくなります。

それぞれ以下からダウンロード
・zlib:http://jarp.does.notwork.org/win32/   →zlib-1.1.4-1-mswin32.zipをダウンロード
・openssl: http://code.google.com/p/openssl-for-windows/downloads/list

ダウンロードしたファイルを解答すると、どちらも中にbinフォルダがあるので、zlib.dll、ssleay32.dll、libeay32.dllをrubyフォルダ下のbinフォルダ内に入れます。

 gemからrailsをインストール
コマンドプロンプトで以下のコマンドを入れてrailsをインストール。
gem install rails

バージョンを指定する場合は以下のような感じで。
gem install rails --version 2.4.7

Successfully installed rails-[バージョン]と出たら成功です!

posted by トモト | 21:58 | インストール | comments(0) | trackbacks(0) |はてなブックマーク - Windowsでrailsをインストールする
スポンサーサイト
posted by スポンサードリンク | 21:58 | - | - | - |はてなブックマーク - スポンサーサイト
コメント
コメントする










この記事のトラックバックURL
http://hajimete-ruby.jugem.jp/trackback/57
トラックバック
Rails3レシピブック 190の技
Rails3レシピブック 190の技
ついにRails3対応版が出ました!!
WEB+DB PRESS Vol.58
WEB+DB PRESS Vol.58
Rails2系から3への移行時に知りたいことがひとまとまりになっててよかった!色々ググるよりこれを読む方が早い。
Rubyレシピブック 第3版 303の技
Rubyレシピブック 第3版 303の技
Rubyやるならこのリファレンスは必要。
Search this site